Description
You attempted to initiate an outbound phone call or send a message, but the To phone number you supplied was not a valid phone number or was incorrectly formatted. Platform accepts phone numbers in E164 format: [+] [country code] [subscriber number including area code].
Possible Causes
The formatting of the To number you supplied was invalid.
- You attempted to send a message or place a call from a Lead Connector number to itself (i.e. putting the same Lead Connector number in the To and From parameters).
- You attempted to send a message to Short Code.
- You attempted to send a message to an Alphanumeric Sender ID.
- You attempted to send a message to a To number with an invalid prefix using a Messaging Service.
Possible Solutions
- Ensure you have formatted your phone numbers in E164 format: [+] [country code] [subscriber number including area code].
- Ensure you have used the correct country calling code for the phone number you are calling.
- Ensure you are not attempting to call or message from a Lead Connector number to itself.
- Ensure you are not attempting to send messages to Short Codes or Alphanumeric Sender IDs. These sender types cannot receive messages from Lead Connector numbers.
- Review the 'To' number for any typos or incorrect input methods.
- When sending messages using a Messaging Service, instead of formatting a To number with an invalid prefix, remove the prefix and send directly to the To number using E164 format: [+] [country code] [subscriber number including area code]. If the To number is able to accept RCS messages and there is an RCS Agent available in the Messaging Service Sender Pool, it will be selected to send to the given To number.